Apps not working on google assistant

My cricket scores app and telegram app,both are working fine on the prototype tab and google actions simulator but not working on the google assistant. The apps start when i call for them but then after my second utterance it starts showing web results. for example when i say “Talk to the cricket scores app”, the app starts to run and asks me for the team name. But after i tell the team name it shows web results about the team. I’ve even tried typing the team name. Even that doesn’t work. Now I’m stuck because we can only have two projects on voiceflow and I can’t just delete these two and create other projects.

1 Like

And for the telegram app it asked me the message i wanted to send. I said “hello” and the assistant replied back “namaste,what can i do for you” instead of sending it to the channel. :neutral_face:

I think you haven’t set an intent name for your project and thus you aren’t getting desired result. Go to develop tab of Google Actions Console and set an intent name and try executing your project.

@Deepanjali For this first check the app name that you have saved on google Actions console in accordance with that the first utterance u have to use talk to my_app_name

@SiddharthBhandarkar @subham3140 I set the main invocation to ‘Talk to My cricket scores project’ and still its the same. The app works fine upto asking me which team’s score i want and then leaves after I utter the team name and shows web results instead.

@Deepanjali Please share the screen shot

Do you get it?

I can also upload the snaps of project flows though I know that there’s nothing wrong in them.

@ashwin.salgaocar sir please look into this I’ve been waiting from 2 days to move forward.

Hi, As can be seen from your screenshots, the app closes soon as you utter Delhi Capitals. This may be because the API request was not successful. Please make sure you test the API block and see if you are getting a proper response. Also, post the screenshots of the Design tab of Voiceflow.

Here…Also I tested the api blocks again,they’re working. Moreover if there’s mistake in the api block, then the apps shouldn’t work on my google actions console ,but they’re working on the google actions simulator as well as in the prototype tab.


@ashwin.salgaocar sir???

@Deepanjali Apologies for the delay. This is a very strange issue. Usually if it works on the Actions Console, it should work on the Assistant app as well. Could you send a screenrecording of the whole process so that I can have a look at it and pin point issues if any?

Sir , i m facing the same problem

After I finish my first project. As per the next step guided, with my same gmail account I was using, I tried to CONNECT TO GOOGLE.
But the login fails. It prompts me to connect to Google developer account. (please take a look of my screen shot attached)
As the pages redirected it leads to download page of google playstore for GOOGLE DEVELOPER ACCOUNT, with payment procedure.

What actually have to do, for CONNECT TO GOOGLE step?

@akshaya9711 do you have the same account in google and Voiceflow as well that you are using in Voiceflow?

Yes. The same gmail account. But still it fails to login.

@akshaya9711 just go to your account in Voiceflow and see whether the button shows “reset” Or not, if it shows reset then it’s fine if not than i think that’s the main problem

There’s is no reset option found. Only the same step of " Sign-in with Google" -option is left out.

As if it’s showing “unlinked” means u have to link it with Voiceflow creator tool,

so when you click on “Upload to google”
It will let you jump to this page

Now when you select your linked account then it will drop you to this page

And then just go the below of this page and click on “Allow” Then it will drop u to this page

Are you getting the same page?

@akshaya9711 ok don’t worry just see the steps once, are you getting the same as I?