Music Player App or Napster API isn't working but everything looks pretty fine. error : No intent matched or reprompt found

Web Link :

First is a screenshot which flows good from block 1 to block 6.It stops executing Block 7 to remaining block. In 5th block capture, I gave “custom” as input type.
Second, is a screenshot of a complete prototype Napster API or Music Player App.

@VenkataRamanen That might be because there is an error from block 7 onwards. Please share the screenshots of the contents of those blocks for me to pin point the issue

Screenshot of all those blocks with Content from Block 5 to Block 12

Complete Voiceflow Prototype of Music Player App with Napster API.

web link :

@VenkataRamanen Could you please add as a collaborator in your project? I shall look into your issue. Here are the steps for same:

  1. Open your Project in VoiceFlow
  2. On Top Right, Click on Share Button
  3. Add in the email field and role as editor.

Let me know once done.

Send an invite. Project named “Music Player App”

I have made edits to your code and it is working fine. The song will play once you upload it to Google Actions. You were using top_5_artists in the code of Block 6 in your project. But you have earlier defined it as top_5_artist in previous blocks. So I have changed top_5_artists to top_5_artist in Block 6.

1 Like

Unable to play audio error occurred.

Hi @VenkataRamanen,

As I mentioned above, the song will not play in the Voiceflow prototype tab. You will have to upload it to Google Action Simulator to play the song. Just test it via Google action simulator/Google assistant to play the song.

Thank you for resolving issues.

1 Like

Hi @shobhit.kumawat can you please check mine as well because even m struck and i tried to check code and all but still not able to find whats going wrong

@prajyoti291999 Could you please share the screenshot of the error where you are stuck? Do include a screenshot of custom code as well to better help you with your issue.

Hi @shobhit.kumawat could you look into my issue, my app runs properly in the Voiceflow prototype tab
but doesn’t work in the action simulator, and I think the problem is the variable ‘tracks’ I have declared it globally but it doesn’t work in the action simulator, it stops right after it takes the track name. Help me solve this please.

@nbsbharath Please share the screenshot of your voiceflow. It’s better to give the prototype link of your voiceflow, so that I can help you.

@rajesh.penugonda here’s the screenshot of the design

and the link to the prototype

@nbsbharath Your voiceflow seems correct and prototype is also working fine. I am not getting why it is not working in the Google Actions Simulator, Let’s have a meet and resolve the issue. Please tell the preferable time tomorrow.

@rajesh.penugonda I will be free from 3 pm

@nbsbharath Great. I will share the meet link tomorrow at 2:50 PM.