Rendering error While uploading on google

Sir I am getting rendering error while uploading my project on google.

The probable reasons could be: Poor internet connection or you must have created wrong API key. Make sure that you have created the API key using the Dialog flow API Admin. For poor internet connection you must try uploading the JSON file again because the Voice flow sometimes may fail to upload the same. All the best.

Sir, I have created api through dialogflow only.But again and again I am getting the same error.i have created a second second project also but again and again I am getting rendering error…

same here, this is happening from yesterday with me also i have done many projects before it worked fine but yesterday when i was doing one and tried to upload the error came.

It is a voiceflow bug which is creating problem for a while now. Even I faced the same problem. The other day I kept trying uploading the JSON file and it was successful. Sometimes it works. Also I think as the Google console has updated their policies it can also be one of the problem. I hope the admin of the forum helps us with this issue.

1 Like

Just when I was typing the above reply. I tried and found one fix; I don’t know yet if it is a major fix or not but before rendering the project make sure you integrate the Google Assistant actions builder to your project in Dialogflow and then try rendering the project. The main reason executing the above fix is that as the Google console has updated its policies. Now possibly it is working on testing and training phenomenon. So as you integrate the Google Assistant actions builder in the dialogflow, first it tests the same and as you upload the JSON file it completes the training of the project.
The reason I am claiming this as a fix because I saw two popups reading: 1.testing project successfully and project successfully. I never seen them before also I couldn’t screenshot them to attach here. I request everyone to follow the above mention steps and share their experience to validate my idea of possible fix. Thanks and Regards


can you pls explain how to do it?

Follow the Dialogflow and Google actions console steps as given in the course lectures. Of late their are few updates in both Dialogflow and Google console.
To jump from the Dialogflow to Google console, click on the Project Id that is been created in Dialogflow. Look for the service account in the Google console for creating the project there as well, Create the API key via service account you created. Parallely integrate the Google assistant app in dialogflow (Click on the test button) and lastly upload the API key to the Voiceflow.
Hope this could help. All the best.

1 Like

My issue is not solved. Can you suggest any different way ?

i am getting the same error .pls help

Please share the steps you executed, must have missed something

share the steps you followed, must have missed something.

i did not get the service account link so i clicked on the project id and went to google cloud platform and searched for service account. I found create service account button and clicked on it and followed the steps instructed in the class videos. I created the key and downloaded the json file in my laptop. In voiceflow, i clicked on upload to google and uploaded the downloaded json file and clicked on upload .But it is showing rendering error . pls help

You missed a very important step of integrating the Google Assistant App in Dialogflow until and unless you don’t do it the body of the whole project is incomplete and thus the error says project is unstructured and shall remain the same. Try doing it.

How to do it? This step is not in the course video

It seems you have completely missed the Dailogflow process if not you have definitely missed this part. Check the highlighted points. 1.Integrations and 2. Test


issue solved thank you so much

1 Like

by clicking TEST ,after that what i have to do?
@sheerin2198 @SiddharthBhandarkar

Upload the API key (JSON file) generated in Google console on Voiceflow. Doing this your project should be ready to work.